Debian Security Advisory 1968 pdns-recursor – several vulnerabilities

6
It was discovered that pdns-recursor, the PowerDNS recursive name server, contains several vulnerabilities:

 

CVE-2009-4009
A buffer overflow can be exploited to crash the daemon, or potentially execute arbitrary code.

CVE-2009-4010
A cache poisoning vulnerability may allow attackers to trick the server into serving incorrect DNS data…

Read More