<!DOCTYPE html>
<html  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# og: http://ogp.me/ns# article: http://ogp.me/ns/article# og: http://ogp.me/ns# book: http://ogp.me/ns/book# og: http://ogp.me/ns# profile: http://ogp.me/ns/profile# og: http://ogp.me/ns# video: http://ogp.me/ns/video# og: http://ogp.me/ns# product: http://ogp.me/ns/product# og: http://ogp.me/ns# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# og: http://ogp.me/ns# sioc: http://rdfs.org/sioc/ns# og: http://ogp.me/ns# sioct: http://rdfs.org/sioc/types# og: http://ogp.me/ns# skos: http://www.w3.org/2004/02/skos/core# og: http://ogp.me/ns# xsd: http://www.w3.org/2001/XMLSchema# og: http://ogp.me/ns#">

<head>
  <meta charset="utf-8" />
<script>
      dataLayer = [{"gtm.whitelist":["google","nonGooglePixels","nonGoogleScripts","nonGoogleIframes"],"gtm.blacklist":["customScripts","customPixels"],"loggedIn":false,"byline":"Paul Brown","publishDate":"March 27, 2017","contentType":"imagex_news","contentSource":"Freelance","audience":["Developer","SysAdmin"],"resources":["Event"],"general":["Enterprise","Tools"],"collaborativeProjects":["Node.js"]}, {"event":"generalPush","general":"Enterprise"},{"event":"generalPush","general":"Tools"},{"event":"collaborativeProjectsPush","collaborativeProject":"Node.js"}]
    </script><link rel="shortcut icon" href="https://www.linux.com/sites/all/themes/custom/lcom/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="The growing number of Netflix subscribers -- nearing 85 million at the time of this Node.js Interactive talk -- has generated a number of scaling challenges for the company. In his talk, Yunong Xiao, Principal Software Engineer at Netflix, describes these challenges and explains how the company went from delivering content to a global audience on an ever-growing number of platforms, to supporting all modern browsers, gaming consoles, smart TVs, and beyond." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.linux.com/news/event/nodejs/2017/3/slaying-monoliths-netflix-nodejs" />
<link rel="shortlink" href="https://www.linux.com/news/event/nodejs/2017/3/slaying-monoliths-netflix-nodejs" />
<meta property="og:site_name" content="Linux.com | The source for Linux information" />
<meta property="og:type" content="website" />
<meta property="og:title" content="Slaying Monoliths at Netflix with Node.js" />
<meta property="og:url" content="https://www.linux.com/news/event/nodejs/2017/3/slaying-monoliths-netflix-nodejs" />
<meta property="og:description" content="The growing number of Netflix subscribers -- nearing 85 million at the time of this Node.js Interactive talk -- has generated a number of scaling challenges for the company. In his talk, Yunong Xiao, Principal Software Engineer at Netflix, describes these challenges and explains how the company went from delivering content to a global audience on an ever-growing number of platforms, to supporting all modern browsers, gaming consoles, smart TVs, and beyond." />
<meta property="og:updated_time" content="2017-03-28T08:38:28-07:00" />
<meta property="og:image" content="https://www.linux.com/sites/lcom/files/yunong-xiao-nodejs.png" />
<meta name="twitter:site" content="@linuxfoundation" />
<meta name="twitter:url" content="https://www.linux.com/news/event/nodejs/2017/3/slaying-monoliths-netflix-nodejs" />
<meta name="twitter:title" content="Slaying Monoliths at Netflix with Node.js" />
<meta name="twitter:description" content="The growing number of Netflix subscribers -- nearing 85 million at the time of this Node.js Interactive talk -- has generated a number of scaling challenges for the company. In his talk, Yunong Xiao, Principal Software Engineer at Netflix, describes these challenges and explains how the company went from delivering content to a global audience on an ever-growing number of platforms, to supporting all modern browsers, gaming consoles, smart TVs, and beyond." />
<meta name="twitter:image" content="https://www.linux.com/sites/lcom/files/yunong-xiao-nodejs.png" />
<meta property="article:published_time" content="2017-03-27T07:55:10-07:00" />
<meta property="article:modified_time" content="2017-03-28T08:38:28-07:00" />
<meta itemprop="name" content="Slaying Monoliths at Netflix with Node.js" />
<meta itemprop="description" content="The growing number of Netflix subscribers -- nearing 85 million at the time of this Node.js Interactive talk -- has generated a number of scaling challenges for the company. In his talk, Yunong Xiao, Principal Software Engineer at Netflix, describes these challenges and explains how the company went from delivering content to a global audience on an ever-growing number of platforms, to supporting all modern browsers, gaming consoles, smart TVs, and beyond." />
<meta itemprop="image" content="https://www.linux.com/sites/lcom/files/yunong-xiao-nodejs.png" />
  <title>Slaying Monoliths at Netflix with Node.js | Linux.com | The source for Linux information</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <!--[if IEMobile]><meta http-equiv="cleartype" content="on"><![endif]-->

  <link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_kShW4RPmRstZ3SpIC-ZvVGNFVAi0WEMuCnI0ZkYIaFw.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_7miOmtwKPtgd4frsGApNDqsuxu7-w-bZX3bp__1R3Hc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_XW-lOa7cj7oUUdmEUvbB6oUFqnqQgMi0uKEZyah0J20.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_uAbFkk6cKivjjO4UKZqkz1juBHzU9LrtKczNYRfbaS8.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_5cbi3SM9i3rcoeDY4LY1XAZkzC1DQipCc_NUnkBfAH8.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_nQwtytNsztHNRD8oGYQyyja_LgjxLi44qLISIPyImuw.css" media="all" />
  <script src="//ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js"></script>
<script>window.jQuery || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/jquery/1.7/jquery.min.js'>\x3C/script>")</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_PdiuypZMI8o81AYEdTHwjRslVPEF69JFzr7Y9sMWt4s.js"></script>
<script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};</script>
<script src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_ceBwu4hjY8IhBCcPIeyEkGqp3lrwDvfpFmlHFhtnjEA.js"></script>
<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.10.2/jquery-ui.min.js"></script>
<script>window.jQuery.ui || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/ui/ui/minified/jquery-ui.min.js'>\x3C/script>")</script>
<script src="https://www.linux.com/sites/all/libraries/mediaelement/build/mediaelement-and-player.min.js?v=2.1.6"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_3CmpyxiXfnT7nEm21keh6vTEby3nK74zvnQiR9yb6jU.js"></script>
<script>var mapping = googletag.sizeMapping()
  .addSize([0, 0], [300, 250])
  .addSize([488, 0], [468, 60])
  .addSize([748, 0], [728, 90])
  .build();
googletag.slots["leaderboard1"] = googletag.defineSlot("/2972204/LF_ROS_728x90_468x60_300x250", [[728, 90], [468, 60], [300, 250]], "dfp-ad-leaderboard1")
  .addService(googletag.pubads())
  .defineSizeMapping(mapping);</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([0, 0], [300, 250])
  .addSize([748, 0], [200, 200])
  .addSize([1028, 0], [300, 250])
  .build();
googletag.slots["box1"] = googletag.defineSlot("/2972204/LF_ROS_300x250_200x200", [[300, 250], [200, 200]], "dfp-ad-box1")
  .addService(googletag.pubads())
  .defineSizeMapping(mapping);</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_ItakS9zygyqNsgIrwxzbVdMS0jPrVDLZnFQsJeR8aZw.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_OVAOz6xKTt0o5QhoWFs7HJDiUhoqOR7FmnZl8WEbty4.js"></script>
<script>googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_YBDYs7heXRixjwSbdGrTzbuys9Ua3jHX0Te6thYuaJ4.js"></script>
<script>var _vwo_code=(function(){
var account_id=218604,
settings_tolerance=2000,
library_tolerance=1500,
use_existing_jquery=false,
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_PYNGGfTB8Qxjxb-2RN9ZA9DVLz07EObe5pCuqFNAS54.js"></script>
<script>(function(h,o,t,j,a,r){
  h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
  h._hjSettings={hjid:'134680',hjsv:5};
  a=o.getElementsByTagName('head')[0];
  r=o.createElement('script');r.async=1;
  r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
  a.appendChild(r);
})(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');</script>
<script>window.a2a_config=window.a2a_config||{};window.da2a={done:false,html_done:false,script_ready:false,script_load:function(){var a=document.createElement('script'),s=document.getElementsByTagName('script')[0];a.type='text/javascript';a.async=true;a.src='https://static.addtoany.com/menu/page.js';s.parentNode.insertBefore(a,s);da2a.script_load=function(){};},script_onready:function(){da2a.script_ready=true;if(da2a.html_done)da2a.init();},init:function(){for(var i=0,el,target,targets=da2a.targets,length=targets.length;i<length;i++){el=document.getElementById('da2a_'+(i+1));target=targets[i];a2a_config.linkname=target.title;a2a_config.linkurl=target.url;if(el){a2a.init('page',{target:el});el.id='';}da2a.done=true;}da2a.targets=[];}};(function ($){Drupal.behaviors.addToAny = {attach: function (context, settings) {if (context !== document && window.da2a) {if(da2a.script_ready)a2a.init_all('page');da2a.script_load();}}}})(jQuery);a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.callbacks.push({ready:da2a.script_onready});a2a_config.templates=a2a_config.templates||{};a2a_config.num_services = 5;
    a2a_config.prioritize = ["email", "facebook", "twitter", "linkedin", "pinterest", "google_plus"];</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_h1lDMTrnEZD5OYT82JLf5ycCK0cJAImbsG7ng0GSloQ.js"></script>
<script>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</script>
  </head>
<body class="html not-front not-logged-in one-sidebar sidebar-second page-node page-node- page-node-325431 node-type-imagex-news section-news page-panels" >
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-NXGNZW" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-NXGNZW');</script>
<!-- End Google Tag Manager -->
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<div id="page">

    <div class="region region-header-top">
    <div class="container">
      
<div id="block-dfp-leaderboard1" class="block block-dfp first last odd lf_header_leaderboard_ad">

    
	<div class="block__content">
	  <div id="dfp-ad-leaderboard1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-leaderboard1" class="dfp-tag-wrapper">
  <div class="slug">Advertisement</div>  <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-leaderboard1");
    });
  </script>
</div>
</div>	</div>

</div>
    </div>
  </div>

  <header class="header" id="header" role="banner">

    <!-- Toggles -->
    <div class="header__toggles">
      <a id="nav__toggle" href="#"><span></span></a>
      <a id="search__toggle" href="#"><span></span></a>
    </div>

    <div class="header__inner">
      <div class="container header__container">

                  <div class="header__site-info" id="name-and-slogan">

                          <a href="/" title="Home" rel="home" class="header__logo" id="logo"><img src="https://www.linux.com/sites/all/themes/custom/lcom/logo.png" alt="Home" class="header__logo-image" /></a>
            
            
                          <div class="header__site-slogan" id="site-slogan">News for the Open Source Professional</div>
                      </div>
        
        
          <div class="header__region region region-header">
    
<div id="block-linux-user-login-logout-links" class="block block-linux-user first odd ">

    
	<div class="block__content">
	  <a href="/cas?destination=node/325431" rel="noindex, nofollow">Login / Create Account</a>	</div>

</div>

<div id="block-menu-menu-join-us" class="block block-menu even join-us" role="navigation">

    
	<div class="block__content">
	  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://www.facebook.com/TheLinuxFoundation" class="menu__link addthis-facebook" target="_blank">Facebook</a></li>
<li class="menu__item is-leaf leaf"><a href="https://twitter.com/linuxfoundation" class="menu__link addthis-twitter" target="_blank">Twitter</a></li>
<li class="menu__item is-leaf leaf"><a href="https://plus.google.com/105083814157272466314" class="menu__link addthis-googleplus" target="_blank">Google Plus</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.linkedin.com/groups?gid=48682" class="menu__link addthis-linkedin" target="_blank">LinkedIn</a></li>
<li class="menu__item is-leaf last leaf"><a href="/feeds" class="menu__link addthis-rss">Feeds</a></li>
</ul>	</div>

</div>

<div id="block-boxes-brought-lf" class="block block-boxes block-boxes-simple last odd lf-brought">

    
	<div class="block__content">
	  <div id='boxes-box-brought_lf' class='boxes-box'><div class="boxes-box-content">
      <p><span>Brought to you by</span> <a href="http://www.linuxfoundation.org"><img alt="Linux Foundation" src="/sites/all/themes/custom/lcom/images/lf/logo-header.png" /></a></p></div></div>	</div>

</div>
  </div>

      </div>

        
<nav class="main-menu" role="navigation">
  <div class="container">

    
    
    <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/news" class="menu__link">News</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/news/category/enterprise" class="menu__link">Enterprise</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/desktop" class="menu__link">Desktop</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/embeddedmobile" class="menu__link">Mobile &amp; Embedded</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/open-source-practices" class="menu__link">Open Source</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/linux-kernel" class="menu__link">Linux Kernel</a></li>
<li class="menu__item is-leaf leaf"><a href="/devops" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf"><a href="/networking" class="menu__link">Networking</a></li>
<li class="menu__item is-leaf last leaf"><a href="/cloud" class="menu__link">Cloud Computing</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/tutorials" class="menu__link">Tutorials</a></li>
<li class="menu__item is-leaf leaf"><a href="/blogs/linux-foundation" class="menu__link expanded">Open Source Pro</a></li>
<li class="menu__item is-expanded expanded"><span class="menu__link nolink">Learn</span><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/what-is-linux" class="menu__link">What is Linux?</a></li>
<li class="menu__item is-leaf leaf"><a href="/learn/training" class="menu__link">Training</a></li>
<li class="menu__item is-leaf leaf"><a href="/certification" class="menu__link">Certification</a></li>
<li class="menu__item is-leaf leaf"><a href="/events" class="menu__link">Events</a></li>
<li class="menu__item is-leaf last leaf"><a href="/blog/upcoming-free-webinars-linux-foundation" class="menu__link">Webinars</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/community" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/community/participate" class="menu__link">Participate</a></li>
<li class="menu__item is-leaf leaf"><a href="/answers" class="menu__link">Q&amp;A</a></li>
<li class="menu__item is-leaf leaf"><a href="/forum" class="menu__link">Forums</a></li>
<li class="menu__item is-leaf last leaf"><a href="/community/blogs" class="menu__link">Blogs</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded"><span class="menu__link nolink">Resources</span><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/newsletter" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf"><a href="/distributions" class="menu__link">Distributions</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/publications" class="menu__link">Publications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/infographics" class="menu__link">Infographics</a></li>
<li class="menu__item is-leaf leaf"><a href="/photos" class="menu__link">Photos</a></li>
<li class="menu__item is-leaf leaf"><a href="/videos" class="menu__link">Videos</a></li>
<li class="menu__item is-leaf last leaf"><a href="/linux-and-open-source-jobs" class="menu__link">Jobs</a></li>
</ul></li>
</ul>
  </div>
</nav><!-- /#navigation -->

<div id="block-views-ed07b1def74a71b1f939ef53b3d18ead" class="block block-views last even search-block">

  <div class="container">
        
    <a id="search__toggle_desktop" href="#"><span></span></a>

    <div class="block__content">
      <form action="/search" method="get" id="views-exposed-form-linux-search-node-panel-pane-1" accept-charset="UTF-8"><div><div class="views-exposed-form">
  <div class="views-exposed-widgets clearfix">
          <div id="edit-keyword-wrapper" class="views-exposed-widget views-widget-filter-search_api_views_fulltext">
                        <div class="views-widget">
          <div class="form-item form-type-textfield form-item-keyword">
 <input type="text" id="edit-keyword" name="keyword" value="" size="30" maxlength="128" class="form-text required error" />
</div>
        </div>
              </div>
                    <div class="views-exposed-widget views-submit-button">
      <input type="submit" id="edit-submit-linux-search-node" name="" value="Search" class="form-submit" />    </div>
      </div>
</div>
</div></form>    </div>
  </div>

</div>

    </div>
  </header>

  
  <div id="main">
    <div class="container">
      <div id="content" class="column" role="main">
                        <a id="main-content"></a>
                                                                


<div class="lcom-stacked__header"><div class="panel-pane pane-entity-field pane-user-field-profile-image node-author-image"  >
  
      
  
  <div class="field field-name-field-profile-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/users/bro66"><img typeof="foaf:Image" src="https://www.linux.com/sites/lcom/files/styles/author_profile_image_24x24/public/profile_image/paulbrownprofilepic.jpg?itok=PgncYrYw" width="30" height="30" alt="" /></a></div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-real-author-name-linked-panel-pane-1 node-author"  >
  
      
  
  <div id="view-id-real_author_name_linked-panel_pane_1" class="view view-real-author-name-linked view-id-real_author_name_linked view-display-id-panel_pane_1 view-dom-id-743d34345bdcbd21d5696783b71b21a4">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-linux-name">        <div class="field-content"><a href="/users/bro66">Paul Brown</a></div>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-node-created node-date"  >
  
      
  
  March 27, 2017
  
  </div>
</div><div class="lcom-stacked__main"><div class="panel-pane pane-node-title"  >
  
      
  
  <h1>Slaying Monoliths at Netflix with Node.js</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-image"  >
  
      
  
  <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><div id="file-5016" class="file file-image file-image-png">

        <h2 class="element-invisible"><a href="/files/images/yunong-xiao-nodejspng">yunong-xiao-nodejs.png</a></h2>
    
  
  <div class="content">
    <img typeof="foaf:Image" src="https://www.linux.com/sites/lcom/files/styles/rendered_file/public/yunong-xiao-nodejs.png?itok=a1MorybL" alt="Yunong Xiao" title="Yunong Xiao" /><div class="group-file-info field-group-div"><div class="field field-name-field-caption field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even">Yunong Xiao, Principal Software Engineer at Netflix, describes scaling challenges the company has encountered and explains how the company delivers content to a global audience on an ever-growing number of platforms.</div></div></div><div class="field field-name-field-license field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/licenses/category/linux-foundation" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">The Linux Foundation</a></div></div></div></div>  </div>

  
</div>
</div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-body"  >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>The growing number of Netflix subscribers -- nearing 85 million at the time of this <a href="http://events.linuxfoundation.org/events/archive/2016/node-interactive">Node.js Interactive</a> talk -- has generated a number of scaling challenges for the company. In his talk, Yunong Xiao, Principal Software Engineer at Netflix, describes these challenges and explains how the company went from delivering content to a global audience on an ever-growing number of platforms, to supporting all modern browsers, gaming consoles, smart TVs, and beyond. He also looks at how this led to radically modifying their delivery framework to make it more flexible and resilient.</p>
<p>One of the first steps Netflix took to cope with their swelling subscriber base was to migrate all their infrastructure to the cloud. But somehow, Xiao says, that didn't mean that once the migration complete, the developers could "just sit around and watch TV shows." The cloud, after all, is just somebody else's computer, and scaling for the number of users is just part of the problem. As the number of users increased, so did the number of platforms they had to deliver to. In its first iteration, Netflix only worked on the browsers, and the framework was simply a Java web server that managed everything. The server did more or less everything, both rendering the UI and accessing the data.</p>
<p>Netflix relies on microservices to provide a diverse range of features. For each microservice there is a team of developers that more or less owns the service and provides a client to the Java server to use. The Java server -- the monolith in this story -- suffered from several issues. To begin with, it was very slow to push and innovate. Every time a new show launched and they wanted to add a new roll title to the UI, they had to push the service. If one of the development teams launched a new and improved version of a client, they had to push the service. When a new microservice was added to the existing ones, they had to push the service. Furthermore, increasing the number of supported devices was nearly impossible in any practical sense.</p>
<p>So in the next iteration, the development team migrated to a REST API. This unlocked the ability to support more devices. The new framework also separated the rendering of the UI and the accessing of data processes. However, the REST API also came with its fair share of disadvantages. For one it was inflexible, as it was originally designed for one kind of device and adding new devices was painful. Also, as a different team owned the REST API, the microservices teams were often waiting weeks for API changes to support their own new services.</p>
<p>It also proved inefficient. REST is resource based and every little element on the Netflix UI is a resource. So, in order to, for example, fetch all of a customer's favorite movies, the services had to make multiple round trips to the back end. Ultimately, it proved difficult to maintain, because the API became more complex and bloated as developers tried to retrofit it with more features.</p>
<p>The different developer teams needed flexibility to innovate for the platforms they were supporting, and the resulting REST API was too clunky and restrictive for this. Another evolution of the Netflix framework was required.</p>
<p>The API.NEXT allowed each team to upload their own custom APIs to the servers. The teams could change the scripts (written in Groovy) as much as they liked without affecting other teams. The API service itself could also be updated independently from the APIs that it was serving. The problem was the Monolith was back again, and that led to scaling problems. Netflix has literally thousands of scripts sharing the same space, serving millions of clients. It was common, says, Xiao, to "run out of headspace," be that memory, CPU, or I/O bandwidth. This led to expensive upgrades when more resources were needed. Another thing that even led to outages were errors in the scripts themselves: If a script had a memory leak, for example, it could bring down the system for everyone.</p>
<p>Another problem was what Xiao calls "Developer Ergonomics." The NEXT.API server was a very complex piece of software with multiple moving parts. Scripts could not be tested locally. To test a script, the team had to upload it to a test site, run it, test it, and, if there were any problems, go through the whole process again after troubleshooting the issues. This process was slow and inconvenient and led to the current iteration of the Netflix framework, one in which scalability and availability, and developer productivity are taken into account.</p>
<p>While designing the new framework, it was established that, on the scalability/availability front, one of the goals was to achieve process isolation to avoid the problems the NEXT.API suffered from. It also required that the data access scripts and API servers were kept separate to reduce infrastructure costs. The designers also wanted to reduce the startup time and have immutable deployment artifacts, which would allow to reproduce the different builds.</p>
<p>As for developer productivity, most developers wanted to use the same language (preferably JavaScript) on the server and the client, and not deal with two distinct technologies. They also needed to be able to run tests locally, have faster incremental builds, and an environment that as closely mirrored the production as possible.</p>
<p>The new framework, called New Generation Data Access API, has moved all the data accessing APIs into separate apps running Node.js. Each app is now isolated running in a Docker container. The back-end services are now contained within a Java-based server the Netflix development team calls the Remote Service Layer. The RSL integrates all back-end services under one consistent API. Whenever developers want to deploy a new APIs, they push JavaScript to the server in the form of a Node.js container.</p>
<p>Overall, Netflix's current combined Java/Node-based platform allows for a quicker and easier deployment, with fewer of the issues that plagued prior monolithic approaches.</p>
<p>Watch the complete presentation below:</p>
<p><iframe frameborder="0" height="315" src="https://www.youtube.com/embed/H_iK7jww_j8?list=PLfMzBWSH11xYaaHMalNKqcEurBH8LstB8" width="560"></iframe></p>
<p><em>If you're interested in speaking at or attending Node.js Interactive North America 2017 - happening October 4-6 in Vancouver, Canada - please subscribe to the <a href="http://bit.ly/2hml18m" target="_blank">Node.js community newsletter </a>to keep abreast of dates and deadlines.</em></p></div></div></div>
  
  </div>
<div class="panel-pane pane-node-links"  >
  
      
  
  <ul class="links inline"><li class="addtoany first"><span><span class="a2a_kit a2a_target addtoany_list" id="da2a_1">
      
      <a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share#url=https%3A%2F%2Fwww.linux.com%2Fnews%2Fevent%2Fnodejs%2F2017%2F3%2Fslaying-monoliths-netflix-nodejs&amp;title=Slaying%20Monoliths%20at%20Netflix%20with%20Node.js"></a>
      <a class="a2a_button_email"></a>
    <a class="a2a_button_facebook"></a>
    <a class="a2a_button_twitter"></a>
    <a class="a2a_button_linkedin"></a>
    <a class="a2a_button_pinterest"></a>
    <a class="a2a_button_google_plus"></a>
    </span>
    <script type="text/javascript">
<!--//--><![CDATA[//><!--
if(window.da2a)da2a.script_load();
//--><!]]>
</script></span></li>
<li class="comment_forbidden"><span><a href="/user/login?destination=node/325431%23comment-form">Log in</a> or <a href="/user/register?destination=node/325431%23comment-form">register</a> to post comments</span></li>
<li class="print_html"><a href="/print/325431" title="Display a printer-friendly version of this page." class="print-page" rel="nofollow">Print This</a></li>
<li class="flag-imagex_node_like last"><span><span class="flag-wrapper flag-imagex-node-like flag-imagex-node-like-325431">
      <a href="/flag/flag/imagex_node_like/325431?destination=node/325431&amp;token=8aeb486c061eee63533b61e6acc66d39" title="" class="flag flag-action flag-link-toggle" rel="nofollow">Like</a><span class="flag-throbber">&nbsp;</span>
          (<span class="flag-counter">0 likes</span>)
  </span>
</span></li>
</ul>
  
  </div>
</div><div class="lcom-stacked__footer"><div class="panel-pane pane-panels-mini pane-comment-minipanel node__comments"  >
  
      
  
  <div class="panel-display parrot-panels minipanels minipanel-one-column clearfix" id="mini-panel-comment_minipanel">
  <div class="minipanel-one-wrapper fullwidth">
    <div class="region region-minipanel-one-main">
      <div class="region-inner clearfix">
              </div>
    </div>
  </div>
</div>

  
  </div>
</div><a href="/popup/nojs" class="ctools-use-modal ctools-modal-subscription-modal-style element-invisible" title="">Click Here!</a>      </div>

      
              <aside class="sidebars">
                      <section class="region region-sidebar-second column sidebar">
    
<div id="block-dfp-box1" class="block block-dfp first odd ">

    
	<div class="block__content">
	  <div id="dfp-ad-box1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-box1" class="dfp-tag-wrapper">
  <div class="slug">Advertisement</div>  <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-box1");
    });
  </script>
</div>
</div>	</div>

</div>

<section id="block-views-training-block-1" class="block block-views even lf-training-block">

    	<header>
	    <h2 class="block__title block-title">Training</h2>
		</header>
	  
	<div class="block__content">
	  <div id="view-id-training-block_1" class="view view-training view-id-training view-display-id-block_1 view-dom-id-6e41123d6e1f3b0d6c6f5aa8630afd4b">
            <div class="view-header">
      <div class="see_all_button"><a href="/learn/training">See all</a></div>    </div>
  
  
  
      <div class="view-content">
          <ul>          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfd301-introduction-linux-open-source-development-and-git-7">LFD301 Introduction to Linux, Open Source Development, and GIT</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2017-04-10T00:00:00+00:00">April 10, 2017</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/development-training/introduction-to-linux,-open-source-development,-and-git">Learn more</a></div>  </div></li>
          <li class="views-row views-row-2 views-row-even">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfd460-embedded-linux-development-yocto-project-7">LFD460 Embedded Linux Development with Yocto Project</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2017-04-10T00:00:00+00:00">April 10, 2017</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/development-training/embedded-linux-development-with-yocto-project">Learn more</a></div>  </div></li>
          <li class="views-row views-row-3 views-row-odd views-row-last">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfs465-software-defined-networking-opendaylight-6">LFS465 Software Defined Networking with OpenDaylight</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2017-04-10T00:00:00+00:00">April 10, 2017</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/system-administration-training/software-defined-networking-with-opendaylight">Learn more</a></div>  </div></li>
      </ul>    </div>
  
  
  
  
  
  
</div>	</div>

</section>

<section id="block-linux-blocks-pardot-newsletter-signup-form" class="block block-linux-blocks odd ">

    	<header>
	    <h2 class="block__title block-title">Newsletter</h2>
		</header>
	  
	<div class="block__content">
	  <iframe src="//go.pardot.com/l/6342/2011-03-24/1ATL" width="100%" height="420px" type="text/html" frameborder="0" allowTransparency="true" style="border: 0"></iframe>	</div>

</section>

<section id="block-views-linux-jobs-related-jobs-block" class="block block-views last even ">

    	<header>
	    <h2 class="block__title block-title">Related Jobs</h2>
		</header>
	  
	<div class="block__content">
	  <div id="view-id-linux_jobs-related_jobs_block" class="view view-linux-jobs view-id-linux_jobs view-display-id-related_jobs_block view-dom-id-f61022faa04e666b6c4aa294f15491cd">
        
  
  
      <div class="view-empty">
      <div id="view-id-linux_jobs-all_jobs_block" class="view view-linux-jobs view-id-linux_jobs view-display-id-all_jobs_block view-dom-id-6e2bee08d358c744678877bc20192f85">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://www.dice.com/job/result/10238807/KRISH032817?CMPID=AF_LF_UP_JS_AV_JW__" rel="nofollow" target="_blank">Urgent Need for Teradata DBA @@ Southlake, TX</a></span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://www.dice.com/job/result/10205641/934959?CMPID=AF_LF_UP_JS_AV_JW__" rel="nofollow" target="_blank">Java Architect</a></span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://www.dice.com/job/result/RTX114e2c/4934954?CMPID=AF_LF_UP_JS_AV_JW__" rel="nofollow" target="_blank">Network Administrator</a></span>  </div>  </div>
  <div class="views-row views-row-4 views-row-even views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://www.dice.com/job/result/10116896/934943?CMPID=AF_LF_UP_JS_AV_JW__" rel="nofollow" target="_blank">Hadoop Admin</a></span>  </div>  </div>
    </div>
  
  
  
  
      <div class="view-footer">
      <p class="article-list__link"><a href="https://www.dice.com/jobs?q=linux&l=&CMPID=AF_LF_UP_JS_AV_JW__" rel="nofollow" target="_blank">See all Jobs</a></p>
<span class="related_jobs_block">Jobs provided in partnership with Dice.com</span>    </div>
  
  
</div>    </div>
  
  
  
  
  
  
</div>	</div>

</section>
  </section>
        </aside>
      
    </div>
  </div>

  
    <footer id="footer" class="region region-footer">
  	<div class="container">
    	
<div id="block-menu-block-1" class="block block-menu-block first odd lf-footer-primary-menu footer-menu" role="navigation">

    
	<div class="block__content">
	  <div class="menu-block-wrapper menu-block-1 menu-name-main-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-expanded first expanded menu-mlid-1275"><a href="/news" class="menu__link">News</a><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1281"><a href="/news/category/enterprise" class="menu__link">Enterprise</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1282"><a href="/news/category/desktop" class="menu__link">Desktop</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1283"><a href="/news/category/embeddedmobile" class="menu__link">Mobile &amp; Embedded</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1284"><a href="/news/category/open-source-practices" class="menu__link">Open Source</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1285"><a href="/news/category/linux-kernel" class="menu__link">Linux Kernel</a></li>
<li class="menu__item is-leaf leaf menu-mlid-5595"><a href="/devops" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf menu-mlid-5596"><a href="/networking" class="menu__link">Networking</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-5597"><a href="/cloud" class="menu__link">Cloud Computing</a></li>
</ul></li>
<li class="menu__item is-leaf leaf menu-mlid-1276"><a href="/tutorials" class="menu__link">Tutorials</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1277"><a href="/blogs/linux-foundation" class="menu__link expanded">Open Source Pro</a></li>
<li class="menu__item is-expanded expanded menu-mlid-1278"><span class="menu__link nolink">Learn</span><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1292"><a href="/what-is-linux" class="menu__link">What is Linux?</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1293"><a href="/learn/training" class="menu__link">Training</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1294"><a href="/certification" class="menu__link">Certification</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1295"><a href="/events" class="menu__link">Events</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1296"><a href="/blog/upcoming-free-webinars-linux-foundation" class="menu__link">Webinars</a></li>
</ul></li>
<li class="menu__item is-expanded expanded menu-mlid-1279"><a href="/community" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1297"><a href="/community/participate" class="menu__link">Participate</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1298"><a href="/answers" class="menu__link">Q&amp;A</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1299"><a href="/forum" class="menu__link">Forums</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1300"><a href="/community/blogs" class="menu__link">Blogs</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded menu-mlid-1280"><span class="menu__link nolink">Resources</span><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1301"><a href="/resources/newsletter" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1303"><a href="/distributions" class="menu__link">Distributions</a></li>
<li class="menu__item is-leaf leaf menu-mlid-3808"><a href="/resources/publications" class="menu__link">Publications</a></li>
<li class="menu__item is-leaf leaf menu-mlid-3809"><a href="/resources/infographics" class="menu__link">Infographics</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1286"><a href="/photos" class="menu__link">Photos</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1287"><a href="/videos" class="menu__link">Videos</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-10188"><a href="/linux-and-open-source-jobs" class="menu__link">Jobs</a></li>
</ul></li>
</ul></div>
	</div>

</div>

<div id="block-menu-menu-footer" class="block block-menu even lf-footer-about-menu footer-menu" role="navigation">

    
	<div class="block__content">
	  <ul class="menu"><li class="menu__item is-expanded first last expanded"><a href="/about" class="menu__link">About Linux.com</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/terms-of-use" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/editorial-policy" class="menu__link">Editorial Policy</a></li>
<li class="menu__item is-leaf last leaf"><a href="/contact" class="menu__link">Contact</a></li>
</ul></li>
</ul>	</div>

</div>

<div id="block-boxes-about-lf" class="block block-boxes block-boxes-simple odd lf-about">

    
	<div class="block__content">
	  <div id='boxes-box-about_lf' class='boxes-box'><div class="boxes-box-content">
        <p><a href="http://www.linuxfoundation.org"><img alt="Linux Foundation" src="/sites/all/themes/custom/lcom/images/lf/logo-footer.png" /></a></p>
        <p>The Linux Foundation is a non-profit consortium enabling collaboration and innovation through an open source development model.</p>
        <p><a href="http://www.linuxfoundation.org" class="more">Learn More</a></p></div></div>	</div>

</div>

<div id="block-linux-blocks-linux-fastly" class="block block-linux-blocks even ">

    
	<div class="block__content">
	  <a href="http://www.fastly.com"><img typeof="foaf:Image" src="https://www.linux.com/sites/all/themes/custom/lcom/images/fastly-logo.png" alt="Fastly" title="Fastly" /></a>	</div>

</div>

<div id="block-boxes-copyright-infos" class="block block-boxes block-boxes-simple last odd lf-copyright">

    
	<div class="block__content">
	  <div id='boxes-box-copyright_infos' class='boxes-box'><div class="boxes-box-content"><p>&copy; 2016 The Linux Foundation</p></div></div>	</div>

</div>
  	</div>
  </footer>

</div>


  <script src="https://www.linux.com/sites/lcom/files/js/js_EIY91SVu4Ez1BN8UI_1XQnC6AJTb65-lR4DGrCwCjos.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_7h324ifclLGYFxFoatQ4-wnM2It7bPCH8oukRlW-nkY.js"></script>
<script>da2a.targets=[
{title:"Slaying Monoliths at Netflix with Node.js",url:"https:\/\/www.linux.com\/news\/event\/nodejs\/2017\/3\/slaying-monoliths-netflix-nodejs"}];
da2a.html_done=true;if(da2a.script_ready&&!da2a.done)da2a.init();da2a.script_load();</script>
</body>
</html>
