<!DOCTYPE html>
<html  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# og: http://ogp.me/ns# article: http://ogp.me/ns/article# og: http://ogp.me/ns# book: http://ogp.me/ns/book# og: http://ogp.me/ns# profile: http://ogp.me/ns/profile# og: http://ogp.me/ns# video: http://ogp.me/ns/video# og: http://ogp.me/ns# product: http://ogp.me/ns/product# og: http://ogp.me/ns# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# og: http://ogp.me/ns# sioc: http://rdfs.org/sioc/ns# og: http://ogp.me/ns# sioct: http://rdfs.org/sioc/types# og: http://ogp.me/ns# skos: http://www.w3.org/2004/02/skos/core# og: http://ogp.me/ns# xsd: http://www.w3.org/2001/XMLSchema# og: http://ogp.me/ns#">

<head>
  <meta charset="utf-8" />
<script>
      dataLayer = [{"gtm.whitelist":["google","nonGooglePixels","nonGoogleScripts","nonGoogleIframes"],"gtm.blacklist":["customScripts","customPixels"],"loggedIn":false,"byline":"Mike Guthrie","publishDate":"January 11, 2017","contentType":"imagex_news","contentSource":"Partner","contentGroup":["Networking"],"audience":["SysAdmin","Developer","Manager\/Management"],"resources":["Webinar"],"general":["Security","Enterprise","Tools"]}, {"event":"contentGroupPush","contentGroup":"Networking"},{"event":"generalPush","general":"Security"},{"event":"generalPush","general":"Enterprise"},{"event":"generalPush","general":"Tools"}]
    </script><link rel="shortcut icon" href="https://www.linux.com/sites/all/themes/custom/lcom/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="There is nothing a hacker likes more than a tasty Linux machine available on the Internet. In my recent Linux Foundation webinar I shared tactics, tools, and methods hackers use to invade your space. In this blog series, we’ll cover the five easiest ways to keep hackers out and know if they have made it in. Want more information? Watch the free webinar on-demand." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.linux.com/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips" />
<link rel="shortlink" href="https://www.linux.com/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips" />
<meta property="og:site_name" content="Linux.com | The source for Linux information" />
<meta property="og:type" content="website" />
<meta property="og:title" content="How to Keep Hackers out of Your Linux Machine Part 1: Top Two Security Tips" />
<meta property="og:url" content="https://www.linux.com/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips" />
<meta property="og:description" content="There is nothing a hacker likes more than a tasty Linux machine available on the Internet. In my recent Linux Foundation webinar I shared tactics, tools, and methods hackers use to invade your space. In this blog series, we’ll cover the five easiest ways to keep hackers out and know if they have made it in. Want more information? Watch the free webinar on-demand." />
<meta property="og:updated_time" content="2017-01-17T15:16:27+00:00" />
<meta property="og:image" content="https://www.linux.com/sites/lcom/files/security-webinar.jpg" />
<meta name="twitter:site" content="@linuxfoundation" />
<meta name="twitter:url" content="https://www.linux.com/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips" />
<meta name="twitter:title" content="How to Keep Hackers out of Your Linux Machine Part 1: Top Two Security Tips" />
<meta name="twitter:description" content="There is nothing a hacker likes more than a tasty Linux machine available on the Internet. In my recent Linux Foundation webinar I shared tactics, tools, and methods hackers use to invade your space. In this blog series, we’ll cover the five easiest ways to keep hackers out and know if they have made it in. Want more information? Watch the free webinar on-demand." />
<meta name="twitter:image" content="https://www.linux.com/sites/lcom/files/security-webinar.jpg" />
<meta property="article:published_time" content="2017-01-11T16:25:52+00:00" />
<meta property="article:modified_time" content="2017-01-17T15:16:27+00:00" />
<meta itemprop="name" content="How to Keep Hackers out of Your Linux Machine Part 1: Top Two Security Tips" />
<meta itemprop="description" content="There is nothing a hacker likes more than a tasty Linux machine available on the Internet. In my recent Linux Foundation webinar I shared tactics, tools, and methods hackers use to invade your space. In this blog series, we’ll cover the five easiest ways to keep hackers out and know if they have made it in. Want more information? Watch the free webinar on-demand." />
<meta itemprop="image" content="https://www.linux.com/sites/lcom/files/security-webinar.jpg" />
  <title>How to Keep Hackers out of Your Linux Machine Part 1: Top Two Security Tips | Linux.com | The source for Linux information</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <!--[if IEMobile]><meta http-equiv="cleartype" content="on"><![endif]-->

  <link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_kShW4RPmRstZ3SpIC-ZvVGNFVAi0WEMuCnI0ZkYIaFw.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_7miOmtwKPtgd4frsGApNDqsuxu7-w-bZX3bp__1R3Hc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_9Vl_VLDY_mG9a0XWmtaLcvJpPqX2n0i4MixjAQM_Cg4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_uZEIjHLipLoX0YrL0NonE2HQZ-d1olJ-S14fbrAI5dY.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_5cbi3SM9i3rcoeDY4LY1XAZkzC1DQipCc_NUnkBfAH8.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_nQwtytNsztHNRD8oGYQyyja_LgjxLi44qLISIPyImuw.css" media="all" />
  <script src="//ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js"></script>
<script>window.jQuery || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/jquery/1.7/jquery.min.js'>\x3C/script>")</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_PdiuypZMI8o81AYEdTHwjRslVPEF69JFzr7Y9sMWt4s.js"></script>
<script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};</script>
<script src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_ceBwu4hjY8IhBCcPIeyEkGqp3lrwDvfpFmlHFhtnjEA.js"></script>
<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.10.2/jquery-ui.min.js"></script>
<script>window.jQuery.ui || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/ui/ui/minified/jquery-ui.min.js'>\x3C/script>")</script>
<script src="https://www.linux.com/sites/all/libraries/mediaelement/build/mediaelement-and-player.min.js?v=2.1.6"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_3CmpyxiXfnT7nEm21keh6vTEby3nK74zvnQiR9yb6jU.js"></script>
<script>var mapping = googletag.sizeMapping()
  .addSize([0, 0], [300, 250])
  .addSize([488, 0], [468, 60])
  .addSize([748, 0], [728, 90])
  .build();
googletag.slots["leaderboard1"] = googletag.defineSlot("/2972204/LF_ROS_728x90_468x60_300x250", [[728, 90], [468, 60], [300, 250]], "dfp-ad-leaderboard1")
  .addService(googletag.pubads())
  .defineSizeMapping(mapping);</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([0, 0], [300, 250])
  .addSize([748, 0], [200, 200])
  .addSize([1028, 0], [300, 250])
  .build();
googletag.slots["box1"] = googletag.defineSlot("/2972204/LF_ROS_300x250_200x200", [[300, 250], [200, 200]], "dfp-ad-box1")
  .addService(googletag.pubads())
  .defineSizeMapping(mapping);</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_ItakS9zygyqNsgIrwxzbVdMS0jPrVDLZnFQsJeR8aZw.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_OVAOz6xKTt0o5QhoWFs7HJDiUhoqOR7FmnZl8WEbty4.js"></script>
<script>googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_YBDYs7heXRixjwSbdGrTzbuys9Ua3jHX0Te6thYuaJ4.js"></script>
<script>var _vwo_code=(function(){
var account_id=218604,
settings_tolerance=2000,
library_tolerance=1500,
use_existing_jquery=false,
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();</script>
<script>
    Drupal.behaviors.comment_pager_anchor = {
         attach: function(context, settings) {
      var comment_pager_links = jQuery('#js-linux-comments-wrapper .pager a');
      comment_pager_links.each(function(){
        this.href = this.href + '#comments';
      });
     }
    };
  </script>
<script src="https://www.linux.com/sites/lcom/files/js/js_5lLWIkDuQe8W8I6OkH4qkuGQ-xPZO0M9eHOgC1Ko7UA.js"></script>
<script>(function(h,o,t,j,a,r){
  h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
  h._hjSettings={hjid:'134680',hjsv:5};
  a=o.getElementsByTagName('head')[0];
  r=o.createElement('script');r.async=1;
  r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
  a.appendChild(r);
})(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');</script>
<script>window.a2a_config=window.a2a_config||{};window.da2a={done:false,html_done:false,script_ready:false,script_load:function(){var a=document.createElement('script'),s=document.getElementsByTagName('script')[0];a.type='text/javascript';a.async=true;a.src='https://static.addtoany.com/menu/page.js';s.parentNode.insertBefore(a,s);da2a.script_load=function(){};},script_onready:function(){da2a.script_ready=true;if(da2a.html_done)da2a.init();},init:function(){for(var i=0,el,target,targets=da2a.targets,length=targets.length;i<length;i++){el=document.getElementById('da2a_'+(i+1));target=targets[i];a2a_config.linkname=target.title;a2a_config.linkurl=target.url;if(el){a2a.init('page',{target:el});el.id='';}da2a.done=true;}da2a.targets=[];}};(function ($){Drupal.behaviors.addToAny = {attach: function (context, settings) {if (context !== document && window.da2a) {if(da2a.script_ready)a2a.init_all('page');da2a.script_load();}}}})(jQuery);a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.callbacks.push({ready:da2a.script_onready});a2a_config.templates=a2a_config.templates||{};a2a_config.num_services = 5;
    a2a_config.prioritize = ["email", "facebook", "twitter", "linkedin", "pinterest", "google_plus"];</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_h1lDMTrnEZD5OYT82JLf5ycCK0cJAImbsG7ng0GSloQ.js"></script>
<script>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</script>
  </head>
<body class="html not-front not-logged-in one-sidebar sidebar-second page-node page-node- page-node-185938 node-type-imagex-news section-news page-panels" >
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-NXGNZW" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-NXGNZW');</script>
<!-- End Google Tag Manager -->
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<div id="page">

    <div class="region region-header-top">
    <div class="container">
      
<div id="block-dfp-leaderboard1" class="block block-dfp first last odd lf_header_leaderboard_ad">

    
	<div class="block__content">
	  <div id="dfp-ad-leaderboard1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-leaderboard1" class="dfp-tag-wrapper">
  <div class="slug">Advertisement</div>  <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-leaderboard1");
    });
  </script>
</div>
</div>	</div>

</div>
    </div>
  </div>

  <header class="header" id="header" role="banner">

    <!-- Toggles -->
    <div class="header__toggles">
      <a id="nav__toggle" href="#"><span></span></a>
      <a id="search__toggle" href="#"><span></span></a>
    </div>

    <div class="header__inner">
      <div class="container header__container">

                  <div class="header__site-info" id="name-and-slogan">

                          <a href="/" title="Home" rel="home" class="header__logo" id="logo"><img src="https://www.linux.com/sites/all/themes/custom/lcom/logo.png" alt="Home" class="header__logo-image" /></a>
            
            
                          <div class="header__site-slogan" id="site-slogan">News for the Open Source Professional</div>
                      </div>
        
        
          <div class="header__region region region-header">
    
<div id="block-linux-user-login-logout-links" class="block block-linux-user first odd ">

    
	<div class="block__content">
	  <a href="/cas?destination=node/185938" rel="noindex, nofollow">Login / Create Account</a>	</div>

</div>

<div id="block-menu-menu-join-us" class="block block-menu even join-us" role="navigation">

    
	<div class="block__content">
	  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://www.facebook.com/TheLinuxFoundation" class="menu__link addthis-facebook" target="_blank">Facebook</a></li>
<li class="menu__item is-leaf leaf"><a href="https://twitter.com/linuxfoundation" class="menu__link addthis-twitter" target="_blank">Twitter</a></li>
<li class="menu__item is-leaf leaf"><a href="https://plus.google.com/105083814157272466314" class="menu__link addthis-googleplus" target="_blank">Google Plus</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.linkedin.com/groups?gid=48682" class="menu__link addthis-linkedin" target="_blank">LinkedIn</a></li>
<li class="menu__item is-leaf last leaf"><a href="/feeds" class="menu__link addthis-rss">Feeds</a></li>
</ul>	</div>

</div>

<div id="block-boxes-brought-lf" class="block block-boxes block-boxes-simple last odd lf-brought">

    
	<div class="block__content">
	  <div id='boxes-box-brought_lf' class='boxes-box'><div class="boxes-box-content">
      <p><span>Brought to you by</span> <a href="http://www.linuxfoundation.org"><img alt="Linux Foundation" src="/sites/all/themes/custom/lcom/images/lf/logo-header.png" /></a></p></div></div>	</div>

</div>
  </div>

      </div>

        
<nav class="main-menu" role="navigation">
  <div class="container">

    
    
    <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/news" class="menu__link">News</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/news/category/enterprise" class="menu__link">Enterprise</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/desktop" class="menu__link">Desktop</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/embeddedmobile" class="menu__link">Mobile &amp; Embedded</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/open-source-practices" class="menu__link">Open Source</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/linux-kernel" class="menu__link">Linux Kernel</a></li>
<li class="menu__item is-leaf leaf"><a href="/devops" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf"><a href="/networking" class="menu__link">Networking</a></li>
<li class="menu__item is-leaf last leaf"><a href="/cloud" class="menu__link">Cloud Computing</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/tutorials" class="menu__link">Tutorials</a></li>
<li class="menu__item is-leaf leaf"><a href="/blogs/linux-foundation" class="menu__link expanded">Open Source Pro</a></li>
<li class="menu__item is-expanded expanded"><span class="menu__link nolink">Learn</span><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/what-is-linux" class="menu__link">What is Linux?</a></li>
<li class="menu__item is-leaf leaf"><a href="/learn/training" class="menu__link">Training</a></li>
<li class="menu__item is-leaf leaf"><a href="/certification" class="menu__link">Certification</a></li>
<li class="menu__item is-leaf leaf"><a href="/events" class="menu__link">Events</a></li>
<li class="menu__item is-leaf last leaf"><a href="/blog/upcoming-free-webinars-linux-foundation" class="menu__link">Webinars</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/community" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/community/participate" class="menu__link">Participate</a></li>
<li class="menu__item is-leaf leaf"><a href="/answers" class="menu__link">Q&amp;A</a></li>
<li class="menu__item is-leaf leaf"><a href="/forum" class="menu__link">Forums</a></li>
<li class="menu__item is-leaf last leaf"><a href="/community/blogs" class="menu__link">Blogs</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded"><span class="menu__link nolink">Resources</span><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/newsletter" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf"><a href="/distributions" class="menu__link">Distributions</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/publications" class="menu__link">Publications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/infographics" class="menu__link">Infographics</a></li>
<li class="menu__item is-leaf leaf"><a href="/photos" class="menu__link">Photos</a></li>
<li class="menu__item is-leaf leaf"><a href="/videos" class="menu__link">Videos</a></li>
<li class="menu__item is-leaf last leaf"><a href="/linux-and-open-source-jobs" class="menu__link">Jobs</a></li>
</ul></li>
</ul>
  </div>
</nav><!-- /#navigation -->

<div id="block-views-ed07b1def74a71b1f939ef53b3d18ead" class="block block-views last even search-block">

  <div class="container">
        
    <a id="search__toggle_desktop" href="#"><span></span></a>

    <div class="block__content">
      <form action="/search" method="get" id="views-exposed-form-linux-search-node-panel-pane-1" accept-charset="UTF-8"><div><div class="views-exposed-form">
  <div class="views-exposed-widgets clearfix">
          <div id="edit-keyword-wrapper" class="views-exposed-widget views-widget-filter-search_api_views_fulltext">
                        <div class="views-widget">
          <div class="form-item form-type-textfield form-item-keyword">
 <input type="text" id="edit-keyword" name="keyword" value="" size="30" maxlength="128" class="form-text required error" />
</div>
        </div>
              </div>
                    <div class="views-exposed-widget views-submit-button">
      <input type="submit" id="edit-submit-linux-search-node" name="" value="Search" class="form-submit" />    </div>
      </div>
</div>
</div></form>    </div>
  </div>

</div>

    </div>
  </header>

  
  <div id="main">
    <div class="container">
      <div id="content" class="column" role="main">
                        <a id="main-content"></a>
                                                                


<div class="lcom-stacked__header"><div class="panel-pane pane-views-panes pane-real-author-name-linked-panel-pane-1 node-author"  >
  
      
  
  <div id="view-id-real_author_name_linked-panel_pane_1" class="view view-real-author-name-linked view-id-real_author_name_linked view-display-id-panel_pane_1 view-dom-id-ccf2694f9a1799e66149896c95f237e3">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-linux-name">        <div class="field-content"><a href="/users/anch">Mike Guthrie</a></div>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-node-created node-date"  >
  
      
  
  January 11, 2017
  
  </div>
</div><div class="lcom-stacked__main"><div class="panel-pane pane-node-title"  >
  
      
  
  <h1>How to Keep Hackers out of Your Linux Machine Part 1: Top Two Security Tips</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-image"  >
  
      
  
  <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><div id="file-4392" class="file file-image file-image-jpeg">

        <h2 class="element-invisible"><a href="/files/images/security-webinarjpg">security-webinar.jpg</a></h2>
    
  
  <div class="content">
    <img typeof="foaf:Image" src="https://www.linux.com/sites/lcom/files/styles/rendered_file/public/security-webinar.jpg?itok=af6QqiAm" alt="Keep hackers out" title="Keep hackers out" /><div class="group-file-info field-group-div"><div class="field field-name-field-caption field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even">In this series, we’ll cover the five easiest ways to keep hackers out. Watch the free webinar on-demand for more information.
</div></div></div><div class="field field-name-field-license field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/licenses/category/creative-commons-zero" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Creative Commons Zero</a></div></div></div><div class="field field-name-field-source field-type-link-field field-label-hidden"><div class="field-items"><div class="field-item even">Pixabay</div></div></div></div>  </div>

  
</div>
</div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-body"  >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>There is nothing a hacker likes more than a tasty Linux machine available on the Internet. In my recent Linux Foundation webinar I shared tactics, tools, and methods hackers use to invade your space. </p>
<p>In this blog series, we’ll cover the five easiest ways to keep hackers out and know if they have made it in. Want more information? Watch the<a href="http://bit.ly/2j89ISJ"> </a><a href="http://bit.ly/2j89ISJ">free webinar on-demand</a>.</p>
<h3>Easy Linux Security Tip #1</h3>
<p><strong>If you are not using Secure Shell, you should be. </strong></p>
<p>This has been a thing for a very, very long time. Telnet is insecure. rLogin is insecure. There are still services out there that require those services but they shouldn't be exposed to the Internet. If you don’t have SSH just turn off your Internet connection. As we always say: use SSH keys.</p>
<p>Rule No. 1 of SSH: Don't use password authentication. The second rule of SSH is: Don't use password authentication. This is really, really important. </p>
<p>If you have a Linux machine on the Internet for any period of time, you are going to get brute forced. It is just going to happen. The brute force is scripted.  Scanners see port 22 open to the Internet and they have to hammer it hard. </p>
<p>The other thing you can do is you can move SSH off of the standard port which many of us do. That works to prevent a small number of brute force attacks but, in general, just don't use password authentication and you'll be safe.</p>
<p>The third rule of SSH is: All keys have passphrases. A no-passphrase key may as well not be a key at all. I realize that makes services hard to deal with if you are trying to log into something automatically or trying to automate stuff but all keys should have passphrases. </p>
<p>My favorite thing to do is to compromise a host and find home directories with private keys. As soon as I have private keys, it's game over. I can log into anything that the public key provides access to. </p>
<p>If you provide a passphrase or even a password, it doesn't have to be a long passphrase on your keys, then it makes my life much, much more difficult.</p>
<h3>Easy Linux Security Tip #2</h3>
<p><strong>Install Fail2ban. </strong></p>
<p>Those brute force attacks that I was talking about? This helps dramatically. It will automatically activate iptables rules to block repeated attempts to SSH into your machine. Be sure to configure it in such a way that it doesn't lock you out or doesn't take up too many resources. But use it, love it, and watch it. </p>
<p>It has its own logs so make sure to watch them and check to see if it’s actually functioning. That's a really important thing as well.</p>
<p>In <a href="https://www.linux.com/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-2-three-more-easy-security-tips">part 2 of this series</a>, I’ll give you three more easy security tips for keeping hackers out of your  Linux machine. You can also <a href="http://bit.ly/2j89ISJ">watch the entire free webinar on-demand</a> now.</p>
<p><em>Mike Guthrie works for the Department of Energy doing Red Team engagements and penetration testing. </em></p></div></div></div>
  
  </div>
<div class="panel-pane pane-node-links"  >
  
      
  
  <ul class="links inline"><li class="addtoany first"><span><span class="a2a_kit a2a_target addtoany_list" id="da2a_1">
      
      <a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share#url=https%3A%2F%2Fwww.linux.com%2Fnews%2Fwebinar%2F2017%2Fhow-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips&amp;title=How%20to%20Keep%20Hackers%20out%20of%20Your%20Linux%20Machine%20Part%201%3A%20Top%20Two%20Security%20Tips"></a>
      <a class="a2a_button_email"></a>
    <a class="a2a_button_facebook"></a>
    <a class="a2a_button_twitter"></a>
    <a class="a2a_button_linkedin"></a>
    <a class="a2a_button_pinterest"></a>
    <a class="a2a_button_google_plus"></a>
    </span>
    <script type="text/javascript">
<!--//--><![CDATA[//><!--
if(window.da2a)da2a.script_load();
//--><!]]>
</script></span></li>
<li class="comment_forbidden"><span><a href="/user/login?destination=node/185938%23comment-form">Log in</a> or <a href="/user/register?destination=node/185938%23comment-form">register</a> to post comments</span></li>
<li class="print_html"><a href="/print/185938" title="Display a printer-friendly version of this page." class="print-page" rel="nofollow">Print This</a></li>
<li class="flag-imagex_node_like last"><span><span class="flag-wrapper flag-imagex-node-like flag-imagex-node-like-185938">
      <a href="/flag/flag/imagex_node_like/185938?destination=node/185938&amp;token=959055a4e6d482a4d1fd9ae2c9315851" title="" class="flag flag-action flag-link-toggle" rel="nofollow">Like</a><span class="flag-throbber">&nbsp;</span>
          (<span class="flag-counter">7 likes</span>)
  </span>
</span></li>
</ul>
  
  </div>
<div class="panel-pane pane-custom pane-1"  >
  
      
  
  <p><a class="node__comment-count" href="#comments">4 Comments</a></p>
  
  </div>
</div><div class="lcom-stacked__footer"><div class="panel-pane pane-panels-mini pane-comment-minipanel node__comments"  >
  
      
  
  <div class="panel-display parrot-panels minipanels minipanel-one-column clearfix" id="mini-panel-comment_minipanel">
  <div class="minipanel-one-wrapper fullwidth">
    <div class="region region-minipanel-one-main">
      <div class="region-inner clearfix">
        <div class="panel-pane pane-node-comments"  id="comments" >
  
        <h2 class="pane-title">
      Comments    </h2>
    
  
  <form action="/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips" method="post" id="linux-voting-comment-sort-form" accept-charset="UTF-8"><div><a name='comments'></a>
<div id="js-linux-comments-wrapper"><a id="comment-16897"></a>
<article class="comment first odd first odd clearfix" about="/comment/16897#comment-16897" typeof="sioc:Post sioct:Comment">

  <header>
    <p class="submitted">
            <span property="dc:date dc:created" content="2017-01-12T17:36:49+00:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/jasonhall" title="View user profile." class="username" xml:lang="" about="/users/jasonhall" typeof="sioc:UserAccount" property="foaf:name" datatype="">JasonHall</a> | <time pubdate datetime="2017-01-12T17:36:49+00:00">January 12, 2017</time></span>      <a href="/comment/16897#comment-16897" class="permalink" rel="bookmark">Permalink</a>    </p>

            
      </header>

  <span rel="sioc:reply_of" resource="/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>1) Not using password authentication is a terrible idea.  Password authentication is something you know.  Crypto Key authentication is something you have (and have to be managed).  If you are really worried about Password Authentication, use somethink like Google Authenticator which provides 2FA.  Key authentication works great for the cloud structure but once someone has your key, they own your system.  Using 2FA with password authentication stops brute force attacks.</p>
<p>2)  Instead of just blocking ssh or moving it to another port, use a knock daemon.  A knock is a secret code that is sent to the server and an action happens if it is the right knock (in this case, open up port 22 to your specific IP address).  This is much more secure then simply switching ports or using fail2ban. </p></div></div></div>
  
  <ul class="links inline"><li class="comment_forbidden first"><span><a href="/user/login?destination=node/185938%23comment-form">Log in</a> or <a href="/user/register?destination=node/185938%23comment-form">register</a> to post comments</span></li>
<li class="like last"><span><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-like rate-662f2a3d68616f4183408b231bf34535 rate-comment-16897-1-1" id="rate-comment-16897-1-1"><span class="rate-like-count">1 Like</span> <a class="rate-button rate-like-inactive rate-inactive" id="rate-button-1" rel="nofollow" href="/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips?rate=AtOlLXMC_stq2j0Pd-3YSjLGEIRz0JYoNF4pl249UCE" title="Like">Like</a></div></span></li>
</ul></article>

<div class="indented"><a id="comment-16925"></a>
<article class="comment even even clearfix" about="/comment/16925#comment-16925" typeof="sioc:Post sioct:Comment">

  <header>
    <p class="submitted">
            <span property="dc:date dc:created" content="2017-01-16T21:21:08+00:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/ka9q" title="View user profile." class="username" xml:lang="" about="/users/ka9q" typeof="sioc:UserAccount" property="foaf:name" datatype="">KA9Q</a> | <time pubdate datetime="2017-01-16T21:21:08+00:00">January 16, 2017</time></span>      <a href="/comment/16925#comment-16925" class="permalink" rel="bookmark">Permalink</a>    </p>

            
      </header>

  <span rel="sioc:reply_of" resource="/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips" class="rdf-meta element-hidden"></span><span rel="sioc:reply_of" resource="/comment/16897#comment-16897" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>I disagree. A passphrase-protected secret key <em>is</em> both "something you have" (the encrypted key file) and "something you know" (the passphrase). I <em>strongly </em>agree with the recommendation to disable plaintext passwords in ssh and to use only public key authentication with passphrase-encrypted secret keys. It is <em>by far</em> the most important thing you can do to secure a Linux system.</p>
<p>Use the ssh authentication agent and you'll only have to enter your passphrase once per session. That makes things far more convenient (e.g., you can run ssh in shell scripts) as well as more secure.</p></div></div></div>
  
  <ul class="links inline"><li class="comment_forbidden first"><span><a href="/user/login?destination=node/185938%23comment-form">Log in</a> or <a href="/user/register?destination=node/185938%23comment-form">register</a> to post comments</span></li>
<li class="like last"><span><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-like rate-61d971076018b5c09b1a37122fb96065 rate-comment-16925-1-1" id="rate-comment-16925-1-1"><a class="rate-button rate-like-inactive rate-inactive" id="rate-button-3" rel="nofollow" href="/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips?rate=AECWdHsyEw6rGLNy_HGONGuTf4wmlbGE8_LmZ7USOB8" title="Like">Like</a></div></span></li>
</ul></article>
</div><a id="comment-16893"></a>
<article class="comment odd odd clearfix" about="/comment/16893#comment-16893" typeof="sioc:Post sioct:Comment">

  <header>
    <p class="submitted">
            <span property="dc:date dc:created" content="2017-01-12T04:22:01+00:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/cyberfarer" title="View user profile." class="username" xml:lang="" about="/users/cyberfarer" typeof="sioc:UserAccount" property="foaf:name" datatype="">cyberfarer</a> | <time pubdate datetime="2017-01-12T04:22:01+00:00">January 12, 2017</time></span>      <a href="/comment/16893#comment-16893" class="permalink" rel="bookmark">Permalink</a>    </p>

            
      </header>

  <span rel="sioc:reply_of" resource="/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><h3>Easy Linux Security Tip #3
</h3><p>Use TCP Wrappers</p>
<p>Not every IP in the world needs access to your SSH port. You will generally know where you will be logging in from so use hosts.deny and hosts.allow to restrict access to only whitelisted IPs.</p>
<p><a href="https://www.cyberciti.biz/faq/restrict-ssh-access-using-tcpd-tcpwrapper/">https://www.cyberciti.biz/faq/restrict-ssh-access-using-tcpd-tcpwrapper/</a></p>
<p>Easy Linux Security Tip #4</p>
<p>Use Iptables to prevent brute forcing even from a whitelisted IP</p>
<p><a href="https://rudd-o.com/linux-and-free-software/a-better-way-to-block-brute-force-attacks-on-your-ssh-server">https://rudd-o.com/linux-and-free-software/a-better-way-to-block-brute-f...</a>
</p></div></div></div>
  
  <ul class="links inline"><li class="comment_forbidden first"><span><a href="/user/login?destination=node/185938%23comment-form">Log in</a> or <a href="/user/register?destination=node/185938%23comment-form">register</a> to post comments</span></li>
<li class="like last"><span><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-like rate-9a14b0ba7e27f731967329e11c0bf2b7 rate-comment-16893-1-1" id="rate-comment-16893-1-1"><a class="rate-button rate-like-inactive rate-inactive" id="rate-button-5" rel="nofollow" href="/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips?rate=Sx-wEzELzzlMRPZh75FRLqTlLW3Iy8vbZJ2OIjzz_k8" title="Like">Like</a></div></span></li>
</ul></article>

<div class="indented"><a id="comment-16926"></a>
<article class="comment last even last even clearfix" about="/comment/16926#comment-16926" typeof="sioc:Post sioct:Comment">

  <header>
    <p class="submitted">
            <span property="dc:date dc:created" content="2017-01-16T21:19:16+00:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/ka9q" title="View user profile." class="username" xml:lang="" about="/users/ka9q" typeof="sioc:UserAccount" property="foaf:name" datatype="">KA9Q</a> | <time pubdate datetime="2017-01-16T21:19:16+00:00">January 16, 2017</time></span>      <a href="/comment/16926#comment-16926" class="permalink" rel="bookmark">Permalink</a>    </p>

            
      </header>

  <span rel="sioc:reply_of" resource="/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips" class="rdf-meta element-hidden"></span><span rel="sioc:reply_of" resource="/comment/16893#comment-16893" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>I'm not a fan of these two approaches.</p>
<p>Who's to say you will always know in advance where you'll be logging in from? I frequently use public hotspots (which are perfectly secure with ssh) so I <em>don't</em> necessarily know what IP address I'll be logging in from.</p>
<p>I'm also not fond of rules that limit the number of ssh connections I can make in a given period of time. I might have ssh commands in shell scripts that execute it quite frequently. (I use the ssh authentication agent so these invocations don't require me to type my pass phrase each time.)</p>
<p>The best thing you can do <em>by far</em> to secure a UNIX-like system (not just Linux but BSD, OSX, etc) is to disable password authentication and force the use of public key authentication to log in. Once you've done that, the most the brute-force attackers can do is to waste a little CPU time. I don't need a firewall to block an unsuccessful attack, especially when there's always a risk (however minor) of that firewall locking <em>me </em>out.</p></div></div></div>
  
  <ul class="links inline"><li class="comment_forbidden first"><span><a href="/user/login?destination=node/185938%23comment-form">Log in</a> or <a href="/user/register?destination=node/185938%23comment-form">register</a> to post comments</span></li>
<li class="like last"><span><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-like rate-aed79122bb2174b216297d9a74a550ad rate-comment-16926-1-1" id="rate-comment-16926-1-1"><a class="rate-button rate-like-inactive rate-inactive" id="rate-button-7" rel="nofollow" href="/news/webinar/2017/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips?rate=5YQDtxiZ-DCyxWSvyxJ7jF--8PyTx0_yaGkxLdx-tfE" title="Like">Like</a></div></span></li>
</ul></article>
</div></div><input type="hidden" name="form_build_id" value="form-UxTGOTQWOiQM8frT8EFFii0pGVxunENJ_UGcLubMqmI" />
<input type="hidden" name="form_id" value="linux_voting_comment_sort_form" />
<input type="hidden" name="honeypot_time" value="1484999421|EkIpYrqyAaqp6KjnNbNrSB8W68dEF3n7ibzMKOtgUcA" />
<div class="url-textfield"><div class="form-item form-type-textfield form-item-url">
  <label for="edit-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-url" name="url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div></div></form>
  
  </div>
      </div>
    </div>
  </div>
</div>

  
  </div>
</div><a href="/popup/nojs" class="ctools-use-modal ctools-modal-subscription-modal-style element-invisible" title="">Click Here!</a>      </div>

      
              <aside class="sidebars">
                      <section class="region region-sidebar-second column sidebar">
    
<div id="block-dfp-box1" class="block block-dfp first odd ">

    
	<div class="block__content">
	  <div id="dfp-ad-box1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-box1" class="dfp-tag-wrapper">
  <div class="slug">Advertisement</div>  <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-box1");
    });
  </script>
</div>
</div>	</div>

</div>

<section id="block-views-training-block-1" class="block block-views even lf-training-block">

    	<header>
	    <h2 class="block__title block-title">Training</h2>
		</header>
	  
	<div class="block__content">
	  <div id="view-id-training-block_1" class="view view-training view-id-training view-display-id-block_1 view-dom-id-eaa0817ee35260eb4f45e8090fdc2ae4">
            <div class="view-header">
      <div class="see_all_button"><a href="/learn/training">See all</a></div>    </div>
  
  
  
      <div class="view-content">
          <ul>          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfd460-embedded-linux-development-yocto-project-4">LFD460 Embedded Linux Development with Yocto Project</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2017-01-23T00:00:00+00:00">January 23, 2017</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/development-training/embedded-linux-development-with-yocto-project">Learn more</a></div>  </div></li>
          <li class="views-row views-row-2 views-row-even">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfs416-linux-security-2">LFS416 Linux Security</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2017-01-23T00:00:00+00:00">January 23, 2017</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/system-administration-training/linux-security">Learn more</a></div>  </div></li>
          <li class="views-row views-row-3 views-row-odd views-row-last">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfd401-developing-applications-linux-4">LFD401 Developing Applications For Linux</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2017-01-23T00:00:00+00:00">January 23, 2017</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/development-training/developing-applications-for-linux">Learn more</a></div>  </div></li>
      </ul>    </div>
  
  
  
  
  
  
</div>	</div>

</section>

<section id="block-linux-blocks-pardot-newsletter-signup-form" class="block block-linux-blocks odd ">

    	<header>
	    <h2 class="block__title block-title">Newsletter</h2>
		</header>
	  
	<div class="block__content">
	  <iframe src="//go.pardot.com/l/6342/2011-03-24/1ATL" width="100%" height="420px" type="text/html" frameborder="0" allowTransparency="true" style="border: 0"></iframe>	</div>

</section>

<section id="block-views-linux-jobs-related-jobs-block" class="block block-views last even ">

    	<header>
	    <h2 class="block__title block-title">Related Jobs</h2>
		</header>
	  
	<div class="block__content">
	  <div id="view-id-linux_jobs-related_jobs_block" class="view view-linux-jobs view-id-linux_jobs view-display-id-related_jobs_block view-dom-id-a5d815056fe5965fdb0a0cdba59ed118">
        
  
  
      <div class="view-empty">
      <div id="view-id-linux_jobs-all_jobs_block" class="view view-linux-jobs view-id-linux_jobs view-display-id-all_jobs_block view-dom-id-7a067ef87151567eb9a34c1fb86ab03c">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://www.dice.com/job/result/uhgbot/693085?CMPID=AF_LF_UP_JS_AV_JW__" rel="nofollow" target="_blank">Software Engineer - Unix/ Linux</a></span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://www.dice.com/job/result/uhgbot/690633?CMPID=AF_LF_UP_JS_AV_JW__" rel="nofollow" target="_blank">Associate Lead - Java+ RedHat Linux</a></span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://www.dice.com/job/result/10311984/813148?CMPID=AF_LF_UP_JS_AV_JW__" rel="nofollow" target="_blank">Cloud Messaging Solution Engineer</a></span>  </div>  </div>
  <div class="views-row views-row-4 views-row-even views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://www.dice.com/job/result/RTX112172/PCK34686373-588?CMPID=AF_LF_UP_JS_AV_JW__" rel="nofollow" target="_blank">DevOps Engineer</a></span>  </div>  </div>
    </div>
  
  
  
  
      <div class="view-footer">
      <p class="article-list__link"><a href="https://www.dice.com/jobs?q=linux&l=&CMPID=AF_LF_UP_JS_AV_JW__" rel="nofollow" target="_blank">See all Jobs</a></p>
<span class="related_jobs_block">Jobs provided in partnership with Dice.com</span>    </div>
  
  
</div>    </div>
  
  
  
  
  
  
</div>	</div>

</section>
  </section>
        </aside>
      
    </div>
  </div>

  
    <footer id="footer" class="region region-footer">
  	<div class="container">
    	
<div id="block-menu-block-1" class="block block-menu-block first odd lf-footer-primary-menu footer-menu" role="navigation">

    
	<div class="block__content">
	  <div class="menu-block-wrapper menu-block-1 menu-name-main-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-expanded first expanded menu-mlid-1275"><a href="/news" class="menu__link">News</a><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1281"><a href="/news/category/enterprise" class="menu__link">Enterprise</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1282"><a href="/news/category/desktop" class="menu__link">Desktop</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1283"><a href="/news/category/embeddedmobile" class="menu__link">Mobile &amp; Embedded</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1284"><a href="/news/category/open-source-practices" class="menu__link">Open Source</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1285"><a href="/news/category/linux-kernel" class="menu__link">Linux Kernel</a></li>
<li class="menu__item is-leaf leaf menu-mlid-5595"><a href="/devops" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf menu-mlid-5596"><a href="/networking" class="menu__link">Networking</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-5597"><a href="/cloud" class="menu__link">Cloud Computing</a></li>
</ul></li>
<li class="menu__item is-leaf leaf menu-mlid-1276"><a href="/tutorials" class="menu__link">Tutorials</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1277"><a href="/blogs/linux-foundation" class="menu__link expanded">Open Source Pro</a></li>
<li class="menu__item is-expanded expanded menu-mlid-1278"><span class="menu__link nolink">Learn</span><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1292"><a href="/what-is-linux" class="menu__link">What is Linux?</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1293"><a href="/learn/training" class="menu__link">Training</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1294"><a href="/certification" class="menu__link">Certification</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1295"><a href="/events" class="menu__link">Events</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1296"><a href="/blog/upcoming-free-webinars-linux-foundation" class="menu__link">Webinars</a></li>
</ul></li>
<li class="menu__item is-expanded expanded menu-mlid-1279"><a href="/community" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1297"><a href="/community/participate" class="menu__link">Participate</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1298"><a href="/answers" class="menu__link">Q&amp;A</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1299"><a href="/forum" class="menu__link">Forums</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1300"><a href="/community/blogs" class="menu__link">Blogs</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded menu-mlid-1280"><span class="menu__link nolink">Resources</span><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1301"><a href="/resources/newsletter" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1303"><a href="/distributions" class="menu__link">Distributions</a></li>
<li class="menu__item is-leaf leaf menu-mlid-3808"><a href="/resources/publications" class="menu__link">Publications</a></li>
<li class="menu__item is-leaf leaf menu-mlid-3809"><a href="/resources/infographics" class="menu__link">Infographics</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1286"><a href="/photos" class="menu__link">Photos</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1287"><a href="/videos" class="menu__link">Videos</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-10188"><a href="/linux-and-open-source-jobs" class="menu__link">Jobs</a></li>
</ul></li>
</ul></div>
	</div>

</div>

<div id="block-menu-menu-footer" class="block block-menu even lf-footer-about-menu footer-menu" role="navigation">

    
	<div class="block__content">
	  <ul class="menu"><li class="menu__item is-expanded first last expanded"><a href="/about" class="menu__link">About Linux.com</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/terms-of-use" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/editorial-policy" class="menu__link">Editorial Policy</a></li>
<li class="menu__item is-leaf last leaf"><a href="/contact" class="menu__link">Contact</a></li>
</ul></li>
</ul>	</div>

</div>

<div id="block-boxes-about-lf" class="block block-boxes block-boxes-simple odd lf-about">

    
	<div class="block__content">
	  <div id='boxes-box-about_lf' class='boxes-box'><div class="boxes-box-content">
        <p><a href="http://www.linuxfoundation.org"><img alt="Linux Foundation" src="/sites/all/themes/custom/lcom/images/lf/logo-footer.png" /></a></p>
        <p>The Linux Foundation is a non-profit consortium enabling collaboration and innovation through an open source development model.</p>
        <p><a href="http://www.linuxfoundation.org" class="more">Learn More</a></p></div></div>	</div>

</div>

<div id="block-linux-blocks-linux-fastly" class="block block-linux-blocks even ">

    
	<div class="block__content">
	  <a href="http://www.fastly.com"><img typeof="foaf:Image" src="https://www.linux.com/sites/all/themes/custom/lcom/images/fastly-logo.png" alt="Fastly" title="Fastly" /></a>	</div>

</div>

<div id="block-boxes-copyright-infos" class="block block-boxes block-boxes-simple last odd lf-copyright">

    
	<div class="block__content">
	  <div id='boxes-box-copyright_infos' class='boxes-box'><div class="boxes-box-content"><p>&copy; 2016 The Linux Foundation</p></div></div>	</div>

</div>
  	</div>
  </footer>

</div>


  <script src="https://www.linux.com/sites/lcom/files/js/js_EIY91SVu4Ez1BN8UI_1XQnC6AJTb65-lR4DGrCwCjos.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_7h324ifclLGYFxFoatQ4-wnM2It7bPCH8oukRlW-nkY.js"></script>
<script>da2a.targets=[
{title:"How to Keep Hackers out of Your Linux Machine Part 1: Top Two Security Tips",url:"https:\/\/www.linux.com\/news\/webinar\/2017\/how-keep-hackers-out-your-linux-machine-part-1-top-two-security-tips"}];
da2a.html_done=true;if(da2a.script_ready&&!da2a.done)da2a.init();da2a.script_load();</script>
</body>
</html>
