SWAPGS Attack, New Speculative Execution Flaw Affects All Modern Intel CPUs

56

A new variant of the Spectre (Variant 1) side-channel vulnerability has been discovered that affects modern Intel CPUs which leverage speculative-execution, and some AMD processors as well, Microsoft and Red Hat warn. Identified as CVE-2019-1125, the vulnerability could allow unprivileged local attackers to access sensitive information stored in the operating system privileged kernel memory, including passwords, tokens, and encryption keys, that would otherwise be inaccessible. (Source: Hackernews)

Previous articleWindows Terminal Preview v0.3 Released
Next articleRed Hat Launches Enterprise Linux 7.7
Swapnil Bhartiya has decades of experience covering emerging technologies and enterprise open source. His stories have appeared in a multitude of leading publications including CIO, InfoWorld, Network World, The New Stack, Linux Pro Magazine, ADMIN Magazine, HPE Insights, Raspberry Pi Geek Magazine, SweetCode, Linux For You, Electronics For You and more. He is also a science fiction writer and founder of TFiR.io.